2 References

2.1 Normative references

References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies.

The following referenced documents are necessary, partially or totally, for the application of the present document. Their use in the context of this TS is specified by the normative statements that refer back to this clause.

[1] IETF RFC 7252: "The Constrained Application Protocol (CoAP)".IETF RFC 7252: "The Constrained Application Protocol (CoAP)".

[2] oneM2M TS-0004: "Service Layer Core Protocol Specification".

[3] IETF RFC 7959: "Block-Wise Transfers in the Constrained Application Protocol (CoAP)".IETF RFC 7959: "Block-Wise Transfers in the Constrained Application Protocol (CoAP)".

[4] oneM2M TS-0003: "Security solutions".

[5] IETF RFC 6347: "Datagram Transport Layer Security Version 1.2".IETF RFC 6347: "Datagram Transport Layer Security Version 1.2".

[6] IETF RFC 8132: "PATCH and FETCH Methods for the Constrained Application Protocol (CoAP)".IETF RFC 8132: "PATCH and FETCH Methods for the Constrained Application Protocol (CoAP)".

NOTE: While any hyperlinks included in this clause were valid at the time of publication oneM2M cannot guarantee their long term validity.

2.2 Informative references

References are either specific (identified by date of publication and/or edition number or version number) or non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the reference document (including any amendments) applies.

The following referenced documents are not necessary for the application of the present document but they assist the user with regard to a particular subject area.

[i.1] oneM2M Drafting Rules.oneM2M Drafting Rules.

NOTE: Available at http://www.onem2m.org/images/files/oneM2M-Drafting-Rules.pdf.